Discussion:
Renaming QMetaType::construct() to QMetaType::create()?
Kent Hansen
2011-10-06 11:13:40 UTC
Permalink
Hi,
I have this one-year-old patch I finally want to get off my back, hence ...
Who outside of Qt uses QMetaType::construct() and is more than
moderately opposed to a source-incompatible change?

For https://bugreports.qt.nokia.com/browse/QTBUG-12574, I think the
cleanest solution would be to rename construct() to create(). Then the
name is actually symmetric with destroy(), and I can use construct() and
destruct() for placement-new operations.

construct() would be

void construct(int type, void *where, const void *copy);

and the copy argument would _not_ be optional, so that existing code
using construct() would no longer compile, and would have to be changed
to call create().

Regards,
Kent

Loading...