Post by Ville M. VainioBikeshed time!
The whole term "Qt Quick " becomes redundant and annoying when qml becomes
the default way to use Qt. "Qt Quick " Should be just Qt.
Qt Quick can be default, for all I care, but right now having QT +=
declarative in .pro file seems a bit strange to me. It's like QT +=
imperative. I am specifically referring to what we do in the .pro
files and the name of the libraries (the source can still reside in
qtdeclarative/, I don't care). If Quick is the name of the technology,
why not just use that?
My suggestion to rename Gui was more practical. When we ported our
codebase to Qt5, it was filled with:
#ifdef QT5
#include <QtWidgets>
#else
#include <QtGui>
#endif
After we made the above change, things just worked. I am guessing most
Qt based apps have to do the above for no real reason (and similar
change in the .pro files). So, what I was going to suggest later on
was: Keep 'gui' as an alias to 'widgets' module and rename current gui
to something else. This way people can try out Qt5 with their existing
Qt4 code with very minimal changes (and we can avoid the whole widgets
are second rate citizens thread since people can try it out
themselves).
Girish
Post by Ville M. VainioPost by Girish RamakrishnanHi,
Is there a plan to rename declarative module to quick? I would prefer
saying "QT += quick" or "QT += quick2" instead of "QT += declarative".
Isn't declarative more like a programming style?
Also, maybe rename QtGui to QtGraphics/QtGraphicsBase/QtPlatform since
it doesn't provide ui elements these days and a base to build
graphics?
Thanks,
Girish
_______________________________________________
Qt5-feedback mailing list
http://lists.qt.nokia.com/mailman/listinfo/qt5-feedback